Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: BGP with Quagga problem  (Read 1389 times)

paolino

  • Newbie
  • *
  • Posts: 2
    • View Profile
BGP with Quagga problem
« on: March 18, 2016, 05:42:17 PM »

Hi,
I've an BGP tunnel on HE and I've got some problem to configure it.
I've try to setup it on an KVM VM and on an OpenVZ container but I've got the same error!
Right now I've this conf:
root@usa6 /etc/quagga# echo 1 > /proc/sys/net/ipv6/conf/all/forwarding
root@usa6 /etc/quagga# echo 50000 > /proc/sys/net/ipv6/route/max_size

root@usa6 /etc/quagga# cat bgpd.conf
! -*- bgp -*-
!
! BGPd sample configuratin file
!
! $Id: bgpd.conf.sample,v 1.1 2002/12/13 20:15:29 paul Exp $
!
hostname bgpd
password xxxxx
router bgp 135164
bgp router-id 216.189.157.X
neighbor 2001:470:d6:45::1 remote-as 6939
neighbor 2001:470:d6:45::1 next-hop-self
!
address-family ipv6
network 2602:ffc5:170::/47
neighbor 2001:470:d6:45::1 activate
exit-address-family

root@usa6 /etc/quagga# ifconfig
he-ipv6 Link encap:IPv6-in-IPv4
inet6 addr: 2001:470:d6:45::2/64 Scope:Global
UP POINTOPOINT RUNNING NOARP MTU:1480 Metric:1
RX packets:124 errors:0 dropped:0 overruns:0 frame:0
TX packets:168 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:11170 (10.9 KiB) TX bytes:15450 (15.0 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: 2602:ffc5:170::/47 Scope:Global
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

tun0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
inet addr:10.23.223.1 P-t-P:10.23.223.2 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 B) TX bytes:152 (152.0 B)

venet0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
inet addr:127.0.0.2 P-t-P:127.0.0.2 Bcast:0.0.0.0 Mask:255.255.255.255
UP BROADCAST POINTOPOINT RUNNING NOARP MTU:1500 Metric:1
RX packets:1729 errors:0 dropped:0 overruns:0 frame:0
TX packets:1181 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:138564 (135.3 KiB) TX bytes:138581 (135.3 KiB)

venet0:0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
inet addr:216.189.157.70 P-t-P:216.189.157.70 Bcast:216.189.157.70 Mask:255.255.255.255
UP BROADCAST POINTOPOINT RUNNING NOARP MTU:1500 Metric:1
root@usa6 /etc/quagga#

But Quagga don't send routes and if I try to ping:

root@usa6 /etc/quagga# ping6 -I lo ipv6.google.com
PING ipv6.google.com(sc-in-x66.1e100.net) from 2001:470:d6:45::2 lo: 56 data bytes
64 bytes from sc-in-x66.1e100.net: icmp_seq=1 ttl=52 time=286 ms
^C
--- ipv6.google.com ping statistics ---
2 packets transmitted, 1 received, 50% packet loss, time 1000ms
rtt min/avg/max/mdev = 286.977/286.977/286.977/0.000 ms
root@usa6 /etc/quagga#

Some idea?
Logged