• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.

Cannot connect Linux client to tunnel ending on Airport Extreme router

Started by ratcheer, January 03, 2017, 11:48:06 AM

Previous topic - Next topic


This seems to be the proper forum for my questions. If that is incorrect, I apologize.

Mt tunnel endpoint is an Apple Airport Extreme 802.11ac router. I am certain that the tunnel itself is functional, because LAN hosts running both iOS and Windows 7 get IPv6 addresses and IPv6 DNS from it with no reconfiguration at all.

However, I have been struggling for four days trying to get my Arch Linux system configured. I am trying to use systemd-networkd and dhcpcd. The system either reports that there is no IPv6 server available or that there is no route to the host. I have tried setting the route both to the tunnel endpoint address and to the router's link local IPv6 address. I have tried so many things that I no longer understand exactly what I am trying to do.

Here are the configuration files as I think they should be:

# Inform the DHCP server of our hostname for DDNS.

# Use the hardware address of the interface for the Client ID.
# or
# Use the same DUID + IAID as set in DHCPv6 for DHCPv4 ClientID as per RFC4361.
# Some non-RFC compliant DHCP servers do not reply with this set.
# In this case, comment out duid and enable clientid above.

# Persist interface configuration when dhcpcd exits.

# Rapid commit support.
# Safe to enable by default because it requires the equivalent option set
# on the server to actually work.
option rapid_commit

# A list of options to request from the DHCP server.
option domain_name_servers, domain_name, domain_search, host_name
option classless_static_routes
# Most distributions have NTP support.
option ntp_servers
# Respect the network MTU. This is applied to DHCP routes.
option interface_mtu

# A ServerID is required by RFC2131.
require dhcp_server_identifier

# Generate Stable Private IPv6 Addresses instead of hardware based ones
slaac private

# Added by TEC 12/31/2016
denyinterfaces wlp6s0
interface enp4s0
ia_na 1

wired.network for systemd-networkd:


My ip6tables firewall:
Chain INPUT (policy DROP 0 packets, 0 bytes)
pkts bytes target     prot opt in     out     source               destination
   47  5896 ACCEPT     all      lo     *       ::/0                 ::/0
    0     0 ACCEPT     all      *      *       ::/0                 ::/0                 state RELATED,ESTABLISHED
    0     0 ACCEPT     icmpv6    *      *       ::/0                 ::/0
    0     0 ACCEPT     udp      *      *       ::/0                 ::/0                 udp dpt:546

Chain FORWARD (policy DROP 0 packets, 0 bytes)
pkts bytes target     prot opt in     out     source               destination

Chain OUTPUT (policy DROP 0 packets, 0 bytes)
pkts bytes target     prot opt in     out     source               destination
   47  5896 ACCEPT     all      *      lo      ::/0                 ::/0
  123 11596 ACCEPT     all      *      *       ::/0                 ::/0                 state NEW,RELATED,ESTABLISHED
   51  3424 ACCEPT     icmpv6    *      *       ::/0                 ::/0

Does anyone see anything that is obviously wrong or missing?

Thank you,


Another clue: I looked at my son's Macbook Pro, which is also connected to the tunnel and has a full set of tools to show the default route, etc. Its default route points to the LL address, fe80::1. So, I guess that's what I need to try on my Linux system.


Jan 03 15:26:32 tim-arch-ssd dhcpcd[6153]: DUID 00:01:00:01:1f:f9:e6:16:50:e5:49:3a:45:05
Jan 03 15:26:32 tim-arch-ssd dhcpcd[6153]: enp4s0: IAID 49:3a:45:05
Jan 03 15:26:32 tim-arch-ssd dhcpcd[6153]: enp4s0: IAID 00:00:00:01
Jan 03 15:26:32 tim-arch-ssd dhcpcd[6153]: enp4s0: soliciting a DHCPv6 lease
Jan 03 15:26:33 tim-arch-ssd dhcpcd[6153]: enp4s0: soliciting an IPv6 router
Jan 03 15:26:45 tim-arch-ssd dhcpcd[6153]: enp4s0: no IPv6 Routers available
Jan 03 15:27:02 tim-arch-ssd systemd[1]: dhcpcd@enp4s0.service: Control process exited, code=exited status=1
Jan 03 15:27:02 tim-arch-ssd systemd[1]: Failed to start dhcpcd on enp4s0.


DHCPD is for running a service that hands out dynamic addresses.  You don't need that.  You already have a device doing that - your router (the Apple airport extreme device).

What you need to do is turn on the KERNEL options for network autoconfiguration in its compilation settings menu.