Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Client IP not updating via URL  (Read 78 times)

jlandwehr

  • Newbie
  • *
  • Posts: 1
Client IP not updating via URL
« on: November 04, 2018, 08:38:03 AM »

The Client IPv4 address is not updating on my Tunnel Details page of:
https://www.tunnelbroker.net/tunnel_detail.php?tid=xxxxxx

I have been using the instructions here:
https://forums.he.net/index.php?topic=1994.0

https://<USERNAME>:<PASSWORD>@ipv4.tunnelbroker.net/nic/update?hostname=<TUNNEL_ID>

I also tried setting the IP specifically via:
https://<USERNAME>:<PASSWORD>@ipv4.tunnelbroker.net/nic/update?hostname=<TUNNEL_ID>&myip=<IP ADDRESS>

In all cases, the responses are:
good 127.0.0.1
Which is weird even when I specify the myip=

Which is clearly the wrong IP, and it's not updating the Tunnel Details - so my Tunnel no longer works because the server doesn't recognize my IP (which changes frequently from ISP).  I have a curl -4 script running with the URL on a daily basis to keep it updated, but I just discovered my tunnel has been down.

Logged

kcochran

  • Sr. Network Engineer, Hurricane Electric
  • Administrator
  • Sr. Member
  • *****
  • Posts: 409
Re: Client IP not updating via URL
« Reply #1 on: November 05, 2018, 01:02:48 PM »

"good 127.0.0.1" is the defined Dyn API reply for a request which doesn't conform to the requirements.  Most of the time this is thrown because the supplied IP address isn't pingable.
Logged