• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.

Odd IPv6 Routeing issue

Started by charleslacour, July 16, 2019, 12:18:30 PM

Previous topic - Next topic


In my home network I have a EdgeRouter 4 connected to a SonicWall TZ600 firewall. The SonicWall is "core" of my network, it connects to my cable modem via its X1 interface. My internal network is connected to the X0, X3, X4 interfaces that are configured as shared switch ports. The ER4 eth0 interface is connected to the X2 interface of the SonicWall. The ER4 is I have OSPFv2 and OSPFv3 running between the SonicWall and ER4. All of the IPv4 routing works as expected.  I also have a 4 VM Cumulus BGP Spine/Leaf setup that is using OSPF and OSPFv3 with the SonicWall on a VLAN sub-interface X0.123 via one of the virtual leaf VMs.

I am getting a /56 prefix delegation from my ISP and I have broken this up into various /64 networks.  I also have a /64 prefix HE Tunnel interface on the ER4 that I have excluded from OSPFv3.

The issue I am having is that as soon as I put an non-Link Local IPv6 address on one one of the ER4 interfaces or Cumulus VM interfaces that is not physically also on SonicWall all IPv6 traffic that hits the SonicWall is routed to the interface that has the non-Link Local IPv6 address. Looking at the IPv6 routes that I get via OSPFv3 on the SonicWall I just get a route for the /64 network of the address I bind to the interface on the ER4 or Cumulus routers.

I have IPv6 RA enabled on the SonicWall but disabled on the ER4 and Cumulus interfaces. I am advertising both connected and learned routes on both the SonicWall, ER4 and Cumulus. I have a default route ::/0 on the SonicWall going to my ISP IPv6 gateway.

I have tried putting a static route ::/0 on the ER4 to the SonicWall X2 interface address.

I can't seem to get IPv6 routing to work. The only thing I have not done is disable OSPFv3 and put in static routes.

I have no idea what is going on I welcome any suggestions or ideas that might help.  IPv4 throughout this setup works perfectly.