• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.

DNS queries result in "network error", but ping, etc work fine

Started by augustineas, April 14, 2022, 06:54:23 AM

Previous topic - Next topic


I love this tool and use it all the time when I evangelize IPv6 to people.

Unfortunately, in any lookup on the DNS page of the app fails with:

network error

This is regardless of DNS type and regardless of being on AT&T's 5G network, Sprint's network, or any of the WiFi networks I have tested on. I am using mostly Samsung devices running Android 12. Other functions like Ping and Traceroute work just fine.

I think this is the same issue that was reported here: https://forums.he.net/index.php?topic=4116.0.

My uneducated guess is that there is a permissions problem in newer versions of Android with the particular function being used for the DNS part, because it definitely worked for me on earlier versions of Android and I don't think the app itself has changed in a while. Maybe it just needs a recompile with newer options? I don't know much about Android development, but I see notices all the time in apps saying something to that effect.

I use the app to show people that they are already using IPv6 without knowing it. We look at the Interface page and they see the IPv6 addresses on the cellular interfaces. Then we have fun doing DNS lookups of facebook.com and see the hidden words encoded in the IPv6 addresses.

It is a great tool and great for socializing IPv6 since everyone has a device it works on and can see how prevalent it is.




I have the same problem.

I use the HE.NET Network Tools on iOS 15.5 (iPad and iPhone).

I think it worked before the update of iOS to 15.5

It doesn't matter if I use my WiFi or the mobile network.

The result of every DNS Lookup is blank. Also when I enter a DNS server like or

My firewall is open for outside traffic.

Best regards



For iOS devices, this appears to be a likely bug in iOS 15.5 within one of the DNS API functions.  We'll have to see if it get resolved during the 15.6 betas.


If I copy out the code from the macOS GitHub repo for libresolv68 for these functions into a test program, instead of the using current libresolv68.102.2, a change from == to >= at line 246 appears to be the culprit.  Going to presume there was an off-by-one error concern in that region.  Now, the full repercussions of that change, and what a revert would incur, is beyond what I have time to dig into currently, but we know where it is at least.


Thanks for looking into this. Do you have any insights into the Android side?



The android app has been awesome despite last update in 2015. If the dns issue on android 12 can be fixed, that saves the hassle of finding an alternative app.