Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: HowTo get LAN hosts to obtain assigned /48 prefix from FreeBSD router  (Read 8926 times)

blixten

  • Newbie
  • *
  • Posts: 6

Hi!

I got ipv6 working on my freebsd 7.2 box. With my /64. But i can't get my /48 working to my other lan computers.

The freebsd box is acting gateway for me in normal way.
I have tryed to setup dhcp6s but without luck. Can't really find a FAQ or tutorial for this either.

I have 2 NIC in the box, xl0 for internet, fxp0 for LAN.
gif0 created interface for the tunnel.

Routed /48:      2001:470:9e0e::/48
Routed /64:    2001:470:1f0b:f3::/64

Anyone wanna sort some things out for me?

Im not even really sure wich NIC i shall have in dhcp6s.config, shall i use rtadvd aswell?

Best regards
Logged

cjkreklow

  • Newbie
  • *
  • Posts: 3

Unless you need something specific from DHCPv6 you're much better off just using rtadvd.  You can set it up in rc.conf.  Something like the following should work (similar to what I'm using on FreeBSD 8-CURRENT)

Code: [Select]
ipv6_gateway_enable="YES"
ipv6_network_interfaces="fxp0 gif0"
ipv6_ifconfig_fxp0="2001:470:9e0e:1::1 prefixlen 64"
rtadvd_enable="YES"
rtadvd_interfaces="fxp0"

The clients on the LAN will autoconfigure addresses from 2001:470:9e0e:1::/64

HTH
Collin
Logged

blixten

  • Newbie
  • *
  • Posts: 6
Re: HowTo get LAN hosts to obtain assigned /48 prefix from FreeBSD router
« Reply #2 on: October 30, 2009, 07:44:34 AM »

How would my rtadvd.conf look like?

Mine look like this. And it still doesn't work

fxp0:\
   :addrs#1:addr="2001:470:9e0e::":prefixlen#64:tc=ether:
Logged

blixten

  • Newbie
  • *
  • Posts: 6
Re: HowTo get LAN hosts to obtain assigned /48 prefix from FreeBSD router
« Reply #3 on: October 30, 2009, 09:56:47 AM »

it works if i set it up manually but not by rtadvd.
im kinda sure i need dhcp6s for my windows computers :)
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2729
Re: HowTo get LAN hosts to obtain assigned /48 prefix from FreeBSD router
« Reply #4 on: November 01, 2009, 06:07:04 AM »

Quote
im kinda sure i need dhcp6s for my windows computers

Nope, Windows will use Router Adverisement to set up an address.

Are you getting addresses on any other host?
Logged

blixten

  • Newbie
  • *
  • Posts: 6
Re: HowTo get LAN hosts to obtain assigned /48 prefix from FreeBSD router
« Reply #5 on: November 03, 2009, 02:24:13 PM »

got it working now with dhcp6s, but i can't get it to work with static adress.

host kame {
        blixten-pc 00:1F:D0:23:21:38;
        prefix 2001:470:9e0e::/48 infinity;
};

http://pastebin.com/f228ae2a7
my whole dhcp6s.conf file
Logged

jimb

  • Hero Member
  • *****
  • Posts: 805
  • ^^^ Warped picture
Re: HowTo get LAN hosts to obtain assigned /48 prefix from FreeBSD router
« Reply #6 on: November 03, 2009, 02:48:31 PM »

You probably need to use that as a /64 instead of a whole /48.
Logged

blixten

  • Newbie
  • *
  • Posts: 6
Re: HowTo get LAN hosts to obtain assigned /48 prefix from FreeBSD router
« Reply #7 on: November 03, 2009, 10:18:07 PM »

didn't help, i get this error in my /var/log/messages

dhcp6s[11949]: yyerror0: /usr/local/etc/dhcp6s.conf 8: syntax error
dhcp6s[11949]: yyerror0: /usr/local/etc/dhcp6s.conf 8: fatal parse failure: exiting (1 errors)
dhcp6s[11949]: main: failed to parse configuration file

it's the very same error with both /64 and /48 in config file, for the static host thing.
Logged

blixten

  • Newbie
  • *
  • Posts: 6
Re: HowTo get LAN hosts to obtain assigned /48 prefix from FreeBSD router
« Reply #8 on: November 04, 2009, 12:15:30 AM »

Sorry, my fault. Worked with this setting

host kame {
        duid 00:1F:D0:23:21:38;
        prefix 2001:470:9e0e::/48 infinity;
};

basic, changed blixten-pc to duid.
where i thought duid was the name of the computer in the example file. :)
Logged