• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.

DNS or Net problem getting to www.theregister.co.uk

Started by bpier, November 06, 2009, 09:36:23 AM

Previous topic - Next topic


Hey all,

I've had my IPv6 tunnel working just fine for a while now, but have been lately having trouble getting to a particular website, www.theregister.co.uk. I'm using Firefox on a Linux box and can access IPv6 websites with no problem.  As far as I can tell from doing some DNS lookups via dig, the theregister.co.uk site is an IPv4 only site; however, when my browser goes to access the site, I get a page displayed from EV6 Networks (www.ev6.net) at a IPv6 address!  So what gives? 

Further, if I use an older version of the Dillo browser (v0.8.4), which is only using IPv4 net access, I can access the theregister.co.uk website fine at its IPv4 address,

I've tried other browsers, such as Opera and Konqueror to verify my FF results, that use both IPv4 and IPv6 and the same results as the FF browser are displayed.  Would this indicate some IPv6 DNS issue that I'm hitting?
I'm using the HE.net DNS server as my resolver at: 2001:470:20::2

Has anyone come across similar behavior?


I get no such behavior going to the register w/ FF on a dual-stack machine.  Comes up fine.  Uses IPv4 address for the site.


Thanks for checking, and how do you configure your resolver?


Quote from: bpier on November 06, 2009, 11:02:51 AM
Thanks for checking, and how do you configure your resolver?
It's pointed to my own name server (BIND 9). 

I did a dig against the server you listed though, and saw an IPv4.



Curiouser and curiouser!

Well, I've solved my immediate web browsing problem with an hitherto unknown FireFox configuration variable, network.dns.ipv4OnlyDomains, which can hold a list of domains that will only be processed via the IPv4 stack.

Some further research led me to a FF bug report (bug 68796 https://bugzilla.mozilla.org/show_bug.cgi?id=68796), entitled "IPv6 : Some IPv4 addresses won't resolve w/IPv6 OS", with multi-YEARS worth of discussion on the matter/problem.

I've mucked around a lot with various DNS queries trying to find any hole, but haven't found anything definitive.  Then again I tried a query that I must've tried several times with troublesome results:
   dig aaaa @ns1.theregister.co.uk theregister.co.uk
The query just sat there awaiting a time-out; it presumably couldn't find ns1.theregister.co.uk.
So, I queried directly for the nameserver: 
   dig ns1.theregister.co.uk  which responded with:
Then I retried the first query:
   dig aaaa @ theregister.co.uk  and got the expected reply of NOERROR and NO AAAA record.
These queries were to the HE.NET server at 2001:470:20::2.
BUT, this doesn't happen all the time; is this some sort of caching issue?

In any case, I do have a quick solution for my FF browsing, but I suspect that there's something I'm incorrect with the DNS configuration for the theregister.co.uk servers.

Finally, the FF solution doesn't begin to address why the browsers Opera, Konqueror and Elinks also exhibit a similar problem with the website in question, though Dillo does not and works fine.


By using the @ in your dig, you are specifying exactly which nameserver you wish to be querying.  Only the second query you listed was possibly destined to the HE nameserver at 2001:470:20::2 (when you did not use the @ designator it will use the nameservers you have configured on the system, usually found in /etc/resolv.conf).   

In your first example "dig aaaa @ns1.theregister.co.uk theregister.co.uk" you are asking dig to query the nameserver ns1.theregister.co.uk for a "AAAA" record for the address theregister.co.uk.   The fact that it did not return on one query is not disturbing, any number of things could have happened along the way to your request (DNS server down for maintenance, link down to that server, any number of other things - remembering that DNS uses UDP, an unreliable transport protocol).

You can see in the output at the bottom of your dig which server provided the answer.  In this case I specifically requested the output from the HE server, thus in the bottom the server is listed as 2001:470:20::2.  Had I not used the @, my local nameserver would have been listed.
oberon:~ gawul00$ dig aaaa theregister.co.uk @2001:470:20::2

; <<>> DiG 9.6.0-APPLE-P2 <<>> aaaa theregister.co.uk @2001:470:20::2
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 47797
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;theregister.co.uk. IN AAAA

theregister.co.uk. 600 IN SOA ns1.theregister.co.uk. hostmaster.theregister.co.uk. 2009112400 28800 7200 604800 3600

;; Query time: 238 msec
;; SERVER: 2001:470:20::2#53(2001:470:20::2)
;; WHEN: Mon Jan  4 14:46:18 2010
;; MSG SIZE  rcvd: 86

oberon:~ gawul00$

Back to your original question - I too do not get this behavior.  As you can see from my dig, I am getting no AAAA record for that address.  When I access theregister.co.uk, I am getting no http IPV6 traffic on my link (confirmed by "tcpdump 'ip6 and tcp port 80' " which would have included any additional requests that were embedded in the website.

Do you have any add-ons in FF that may be trying to manipulate the page?