Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Pages: 1 [2]

Author Topic: Tunnel Broker not working anymore  (Read 8422 times)

jimb

  • Hero Member
  • *****
  • Posts: 805
  • ^^^ Warped picture
Re: Tunnel Broker not working anymore
« Reply #15 on: May 13, 2010, 04:39:35 PM »

NOTE: this presumes that your XP box is the tunnel box.  If it's just a node on the LAN that already has an IPv6 tunnel router, you simply need to add an address from your routed /64 to your LAN interface, and point a default route to the LAN interface of your router box.

Way over my head...I signed up with Tunnel Broker to create a tunnel. I selected my OS and inserted the commands.
ipv6 rtu ::/0 2/::66.220.18.42 pub
ipv6 adu 2/2001:470:c:51f::2

I'm starting to think its a problem with my ISP because I have a laptop with Vista and it has the same problem. I cannot go onto any ipv6 websites. Just 1 day it stopped working...
Are you trying to establish multiple tunnels from behind a NAT device?  If so, that doesn't work unless you statically map a separate public IPv4 address to each computer behind the NAT device for 6in4 traffic.  Of course, if all these systems have their own public IPv4, then it will work.

Basically, you should have a single box acting as an IPv6 tunnel router box, with all IPv6 traffic going through it.  You may want to have a peek at this thread where someone shows how to do this on an XP box.  Should be applicable to other windows versions too:  http://www.tunnelbroker.net/forums/index.php?topic=918.0

Also, instead of using the 'ipv6' commands it's probably better to use the netsh interface, since the 'ipv6' commands don't exist on vista and win7 and I think they're in a semi-deprecated state.
Logged

mrkazador

  • readonly_member
  • Newbie
  • *
  • Posts: 12
Re: Tunnel Broker not working anymore
« Reply #16 on: May 13, 2010, 06:36:05 PM »

http://www.tunnelbroker.net/forums/index.php?topic=918.0

That link WORKED!!!! I can now visit ipv6 websites.
One of the commands I tried did not work, an error said "The parameter is incorrect." Do you know why? Should I even worry?

netsh interface ipv6>add addr 2001:470:c:51f::1 "Local Area Connection"
The parameter is incorrect.
Logged

jimb

  • Hero Member
  • *****
  • Posts: 805
  • ^^^ Warped picture
Re: Tunnel Broker not working anymore
« Reply #17 on: May 13, 2010, 10:25:03 PM »

http://www.tunnelbroker.net/forums/index.php?topic=918.0

That link WORKED!!!! I can now visit ipv6 websites.
One of the commands I tried did not work, an error said "The parameter is incorrect." Do you know why? Should I even worry?

netsh interface ipv6>add addr 2001:470:c:51f::1 "Local Area Connection"
The parameter is incorrect.

I think the order of the address and interface is backward.  According to my netsh help on "add address":
Code: [Select]
Usage: add address [interface=]<string> [address=]<IPv6 address>
             [[type=]unicast|anycast]
             [[validlifetime=]<integer>|infinite]
             [[preferredlifetime=]<integer>|infinite]
             [[store=]active|persistent]

Parameters:

       Tag                 Value
       interface         - Interface name or index.
       address           - IPv6 address to add.
       type              - One of the following values:
                           unicast: Adds a unicast address (default).
                           anycast: Adds an anycast address.
       validlifetime     - Lifetime over which the address is valid.
                           The default value is infinite.
       preferredlifetime - Lifetime over which the address is preferred.
                           The default value is infinite.
       store             - One of the following values:
                           active: Change only lasts until next boot.
                           persistent: Change is persistent (default).

Remarks: Adds an IPv6 address to a given interface.  Time values can be
         expressed in days, hours, minutes, and seconds; e.g. 1d2h3m4s.

Example:

       add address "Private" fe80::2

So try:  "netsh interface ipv6 add addr "Local Area Connection" 2001:470:c:51f::1"
« Last Edit: May 13, 2010, 10:26:51 PM by jimb »
Logged

mrkazador

  • readonly_member
  • Newbie
  • *
  • Posts: 12
Re: Tunnel Broker not working anymore
« Reply #18 on: May 14, 2010, 12:32:17 AM »

Yeah, that worked. Thank you guys for all the help.
Logged
Pages: 1 [2]