Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Win 7 x64 as Router on LAN for Ubuntu Linux  (Read 4336 times)

gadreel

  • Newbie
  • *
  • Posts: 5
Win 7 x64 as Router on LAN for Ubuntu Linux
« on: May 05, 2011, 04:02:07 PM »

Following the sound advice of

http://www.tunnelbroker.net/forums/index.php?topic=1439.0

I have my Windows 7 running a tunnel just fine.  A second Windows 7 computer on my network also just worked after this (using the RA's from the first machine I suppose).

However, my Ubuntu computer was not so happy.  If I set it to ignore IPv6 then all is fine - but if I set it to any of the "automatic" options (through the network admin ui) it brings down all of eth0. 

This computer cannot be setup as the tunnel end point, so this is out:

ifconfig sit0 up
ifconfig sit0 inet6 tunnel ::209.51.181.2
ifconfig sit1 up
ifconfig sit1 inet6 add 2001:470:ffff:aaaa::2/64
route -A inet6 add ::/0 dev sit1

but I'm guessing that something like that route statement might help.  But thats as far as I can get - spent hours searching, not even sure what for (Windows as ipv6 router for Linux)...  Thanks.
Logged

ratcheer

  • Jr. Member
  • **
  • Posts: 69
Re: Win 7 x64 as Router on LAN for Ubuntu Linux
« Reply #1 on: May 05, 2011, 04:46:47 PM »

Do you have a router that could be used as your tunnel endpoint? I have a LAN with one each of Ubuntu, Windows 7, and Windows XP. My router runs an IPv6 capable version of dd-wrt and it is the tunnel endpoint. It serves IPv6 to the three PC's using radvd. The only one I had any trouble with was the Win 7 PC, partly due to a bug in Win 7. But, it was the most complicated one to configure, too.

Tim
Logged

gadreel

  • Newbie
  • *
  • Posts: 5
Re: Win 7 x64 as Router on LAN for Ubuntu Linux
« Reply #2 on: May 05, 2011, 05:10:32 PM »

Unfortunately I don't have an IPv6 capable router.  Seems like an ideal solution, if I had one.
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2714
Re: Win 7 x64 as Router on LAN for Ubuntu Linux
« Reply #3 on: May 06, 2011, 07:03:50 AM »

What do your routing tables look like on the Ubuntu computer when it's not working?  The output of ifconfig would also be nice to see
Logged

gadreel

  • Newbie
  • *
  • Posts: 5
Re: Win 7 x64 as Router on LAN for Ubuntu Linux
« Reply #4 on: May 06, 2011, 05:49:11 PM »

Sure, here it is:


eth0      Link encap:Ethernet  HWaddr 00:0c:29:51:0d:cd 
          inet addr:192.168.0.5  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:29ff:fe51:dcd/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2992 errors:0 dropped:0 overruns:0 frame:0
          TX packets:613 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:346018 (346.0 KB)  TX bytes:92658 (92.6 KB)
          Interrupt:19 Base address:0x2024

and:

Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
192.168.0.0     *               255.255.255.0   U         0 0          0 eth0
link-local      *               255.255.0.0     U         0 0          0 eth0
default         192.168.0.1     0.0.0.0         UG        0 0          0 eth0

thanks
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2714
Re: Win 7 x64 as Router on LAN for Ubuntu Linux
« Reply #5 on: May 07, 2011, 06:20:00 PM »

There isn't any IPv6 info on that machine whatsoever.

Check to make sure that your tunnel server (or something) is doing RA or DHCP.

If they are, check this host to make sure it's listening for one of the above
Logged

stolen

  • Newbie
  • *
  • Posts: 6
Re: Win 7 x64 as Router on LAN for Ubuntu Linux
« Reply #6 on: May 07, 2011, 10:58:24 PM »

NetworkManager on Ubuntu doesn't play nicely with IPv6, unfortunately. (I think this is the bug https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/284874 )
I've made it work on one machine by swapping to automatic and back to ignore a few times (eventually leaving it on ignore, but IPv6 works).  11.04 may work better for you as well (I haven't tried it yet on that machine).
I've also removed NetworkManager completely on another installation and configured my interfaces in "/etc/network/interfaces", and that works with no issues.

Logged

stolen

  • Newbie
  • *
  • Posts: 6
Re: Win 7 x64 as Router on LAN for Ubuntu Linux
« Reply #7 on: May 25, 2011, 06:58:33 AM »

Happy to report that IPv6 is working nicely on the newest version of Ubuntu when using NetworkManager.  Hooray! :)
Logged