Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: iperf not working: Invalid input  (Read 5932 times)

felixhenet

  • Newbie
  • *
  • Posts: 1
    • View Profile
iperf not working: Invalid input
« on: March 11, 2015, 01:49:42 PM »

Both iperf2 and iperf3 aren't working for me.
Whatever I type into the server name field it says "Invalid input, <server name>" when hitting enter.
I tried both domain names and IPs.

Tested with:
Version 0.5.5 on Nexus 4 with CyanogenMod 11 M12 (Android 4.4.4)
Logged

ZebraSpud

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: iperf not working: Invalid input
« Reply #1 on: March 20, 2015, 07:31:51 PM »

I am getting something similar.   The error is:  "error-unable to create a new stream:  Operation not permitted."

The iOS device shows the error and no additional information
   - iOS 8.2 on iPhone 6+ AND iOS 8.1.1 on iPhone 4s
   - HE.NET Network Tools Version 1.3.1.226
The server shows an established connection and continued status
   - Server: Ubuntu 14.04.2 LTS
   - iperf3:  3.13.0-46-generic
Logged

m10

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: iperf not working: Invalid input
« Reply #2 on: April 25, 2015, 04:10:10 AM »

Hi,

Is there any update on this? I have the same issue as ZebraSpud on iPhone5 as well as iPhone6 and with iOS 8.1 and 8.3
Any solution is really appreciated.

TIA,
m10
Logged

mccreigh

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: iperf not working: Invalid input
« Reply #3 on: May 11, 2015, 11:17:43 AM »

Me, too.  Today I experienced the same problem that ZebraSpud reported.  My HE.NET Network Tools is v1.3.1.226, my iPhone6 iOS is v8.3, and I'm testing against iperf3 (v3.0.11, compiled locally from http://downloads.es.net/pub/iperf/iperf-3.0.11.tar.gz) in server mode on a local Ubuntu 12.04LE host.  Another local Ubuntu 12.04LE host running iperf3 (v.3.0.11) in client mode against that server works perfectly.  HE, when can we look forward to a fix?

Incidentally, if I run an iperf(2) server on that same Ubuntu host, the HE.NET Network Tools iperf2 tool works correctly against it.  But iperf3 is important for me because its default client settings run speed tests in both directions, essential in a WiFi setting where the transmit power of the user device may be much lower than that of the access point.  Alas, the HE iperf tools give us access to just a few of iperf's many parameters.
Logged