Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: tunnel broker endpoint update broken?  (Read 1201 times)

zq265

  • Newbie
  • *
  • Posts: 3
tunnel broker endpoint update broken?
« on: October 14, 2015, 08:46:46 PM »

Hi,

I'm seeing a problem with tunnel broker, every update ends up with "ok 127.0.0.1", and no changes appeared on the control page, neither does 127.0.0.1 shown up.

Details:

Code: [Select]
HTTP/1.0 200 ok
Date: Thu, 15 Oct 2015 03:41:45 GMT
Server: Apache/2.2.22 (Ubuntu) DAV/2 SVN/1.6.17 PHP/5.3.10-1ubuntu3.18 with Suhosin-Patch mod_ssl/2.2.22 OpenSSL/1.0.1 mod_perl/2.0.5 Perl/v5.14.2
X-Powered-By: PHP/5.3.10-1ubuntu3.18
Set-Cookie: referer=Direct+Access
Strict-Transport-Security: max-age=15768000
Vary: Accept-Encoding
Content-Length: 15
Connection: close
Content-Type: text/html; charset=utf-8

good 127.0.0.1

And request:
Code: [Select]
GET /nic/update?hostname=MYTUNNELID&username=zq265&password=MYUPDATEKEY&myip=MyPublicIP HTTP/1.1
Cookie: referer=Direct+Access
Host: ipv4.tunnelbroker.net
Connection: close
User-Agent: Paw/2.2.5 (Macintosh; OS X/10.11.1) GCDHTTPRequest
Logged

kcochran

  • Sr. Network Engineer, Hurricane Electric
  • Administrator
  • Sr. Member
  • *****
  • Posts: 418
Re: tunnel broker endpoint update broken?
« Reply #1 on: October 14, 2015, 10:43:04 PM »

IP isn't pingable.

"good 127.0.0.1" is normally how Dyn-like APIs report that the update wasn't performed due to the remote side not following specifications.
Logged