Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: FreeBSD rc.conf settings issue  (Read 10589 times)

thazer

  • Newbie
  • *
  • Posts: 3
FreeBSD rc.conf settings issue
« on: December 29, 2009, 04:15:09 AM »

Hi! I'll jump right into the problem, i'm a HE ipv6 user for quite a while and now have switched from ubuntu to freebsd and i'm having trouble with starting up the ipv6 settings...
After researching the net i've found http://www.freebsddiary.org/ipv6.php and http://www.tunnelbroker.net/forums/index.php?topic=19.msg26#msg26 but unfortunately they do not apply to my FreeBSD 7.2-RELEASE-p5 the thing is that the route is not set properly...

here's my rc.conf
Code: [Select]
ipv6_enable="YES"
gif_interfaces="gif0"
gifconfig_gif0="86.122.121.171 216.66.80.30"
ipv6_network_interfaces="lo0 gif0"
ipv6_ifconfig_gif0="2001:0470:1f0a:d40::2 2001:0470:1f0a:d40::1 prefixlen 128"
ipv6_defaultrouter="-interface gif0"

but i have to manually execute the
/sbin/route -n add -inet6 default 2001:0470:1f0a:d40::1

for the ipv6 network to work properly
i must say i've tryed to use ipv6_defaultrouter="2001:0470:1f0a:d40::1" and ipv6_ifconfig_gif0="2001:0470:1f0a:d40::2/64" as well in the config but still no joy...

thanks in advance!
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2729
Re: FreeBSD rc.conf settings issue
« Reply #1 on: December 29, 2009, 05:11:46 AM »

Here's what mine looks like

Code: [Select]
ipv6_network_interfaces="fxp0 gif1 lo0"
ipv6_gateway_enable="YES"
ipv6_prefix_fxp0="2001:470:c27d:d000"
gif_interfaces="gif1"
gifconfig_gif1="12.199.185.10 209.51.181.2"
ipv6_ifconfig_gif1="2001:470:1f10:2aa::2/64"
ipv6_defaultrouter="-interface gif1"

Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2729
Re: FreeBSD rc.conf settings issue
« Reply #2 on: December 29, 2009, 05:12:49 AM »

I did have problems when trying to use gif0...I'm still not exactly sure why, but gif1 worked with no problems.
Logged

thazer

  • Newbie
  • *
  • Posts: 3
Re: FreeBSD rc.conf settings issue
« Reply #3 on: December 30, 2009, 04:54:50 AM »

tryed and tryed it always says
Code: [Select]
pgn# ping6 ipv6.google.com
ping6: UDP connect: No route to host

:|
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2729
Re: FreeBSD rc.conf settings issue
« Reply #4 on: December 30, 2009, 07:02:43 AM »

can you post your routing tables (netstat -nr) and output of "ifconfig -a" ?

did you try using gif1 instead of gif0?
Logged

thazer

  • Newbie
  • *
  • Posts: 3
Re: FreeBSD rc.conf settings issue
« Reply #5 on: January 03, 2010, 10:37:29 AM »

i'll try to keep this thread clean and use pastebin, hope this will be ok with all...

here is the basic comand line config from tunnelbroker.net
http://pastebin.ca/1736599


here's the rc.conf
Code: [Select]
defaultrouter="86.122.121.129"
gateway_enable="YES"
hostname="pgn.ro"
ifconfig_nfe0="inet ....."
[...]
ipv6_enable="YES"
ipv6_network_interfaces="lo0 gif1"
ipv6_gateway_enable="YES"
gif_interfaces="gif1"
gifconfig_gif1="86.122.121.171 216.66.80.30"
ipv6_ifconfig_gif1="2001:0470:1f0a:d40::2/64"
ipv6_defaultrouter="-interface gif1"
[...]

after that i do a quick network restart
http://pastebin.ca/1736601

as ipv6 does not work i use route to add the gateaway :
http://pastebin.ca/1736604

p.s. sorry for the old encrypted pastebins...
« Last Edit: January 03, 2010, 11:48:45 PM by thazer »
Logged

jimb

  • Hero Member
  • *****
  • Posts: 805
  • ^^^ Warped picture
Re: FreeBSD rc.conf settings issue
« Reply #6 on: January 03, 2010, 11:42:04 AM »

Just make the pastebin links actual links so people can click on them.  Also, the pastebins are encrypted.  Can't see them without a password.
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2729
Re: FreeBSD rc.conf settings issue
« Reply #7 on: January 04, 2010, 06:21:41 AM »

While this isn't a perfect fix, it would work.

create /etc/rc.local as root

add the following line to it

Code: [Select]

route -n add -inet6 default 2001:0470:1f0a:d40::1

Reboot.

FreeBSD will run that command on restart.
Logged