Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Pages: 1 2 [3] 4 5 ... 10
 21 
 on: June 20, 2017, 05:18:18 AM 
Started by Unfunks - Last post by Unfunks
newbie at this, but how do i delegate my domain name with nameserver?
like: unafunk.com.ns2.he.net
or: just leave domain name in the top line and just have the ns1.he.net in the line under?

Thank you for anwers..:)

this is what i get when ive done :ERROR delegation was not found, pleas delegate to ns1,ns2,ns3,ns4,ns5 and retry.

where am i going wrong?  ::)

 22 
 on: June 20, 2017, 04:49:17 AM 
Started by Unfunks - Last post by Unfunks
newbie at this, but how do i delegate my domain name with nameserver?
like: unafunk.com.ns2.he.net
or: just leave domain name in the top line and just have the ns1.he.net in the line under?

Thank you for anwers..:)

this is what i get when ive done :ERROR delegation was not found, pleas delegate to ns1,ns2,ns3,ns4,ns5 and retry.

where am i going wrong?  ::)

 23 
 on: June 19, 2017, 10:56:16 PM 
Started by tuxthemadpenguin - Last post by snarked
But with numeric input, at least you get an output.....

 24 
 on: June 19, 2017, 08:26:11 AM 
Started by majortom - Last post by majortom
The problem I was having was that PF was blocking 6in4 traffic (protocol 41). I also discovered that I needed to enable the sysctl net.inet6.ip6.forwarding.

Having been through this now, I think I have all the items I need:

The sample configuration the tunnel broker suggests for Mac OS X is this:

ifconfig gif0 create
ifconfig gif0 tunnel CLIENT_IPv4_ADDRESS TUNNEL_SERVER_IPv4_ADDRESS
ifconfig gif0 inet6 CLIENT_IPv6_ADDRESS TUNNEL_SERVER_IPv6_ADDRESS prefixlen 128
route -n add -inet6 default TUNNEL_SERVER_IPv6_ADDRESS

These lines might need to be added to PF (it does not hurt to have them even if they might not be needed):

icmp6_types = "{ unreach, toobig, timex, paramprob, echoreq, echorep, neighbradv, neighbrsol, routeradv, routersol }"   
pass inet6 proto ipv6-frag   
pass in on EXT_INTERFACE proto 41 from TUNNEL_SERVER_IPv4_ADDRESS   
pass out on EXT_INTERFACE proto 41 to TUNNEL_SERVER_IPv4_ADDRESS   
pass in on gif0 inet6 proto icmp6 all icmp6-type $icmp6_types allow-opts   

Finally, if the machine is going to gateway IPv6 traffic:

sysctl net.inet6.ip6.forwading=1

 25 
 on: June 19, 2017, 08:21:14 AM 
Started by majortom - Last post by majortom
Is your firewall blocking protocol 41?

Nope. The Mac that hosts the tunnel works fine, and any downstream system would not use 6in4 (protocol 41), but instead regular IP forwarding. Your question did lead me to the right answer, however, which was sysctl net.inet6.ip.forwarding was false, not true. I corrected that and now it all works. (I was going to add a PF rule to explicitly allow IPv6 6in4 traffic bound for the local /64 and in looking up the syntax I found the sysctl I needed).

Thanks for your help (both direct and inadvertent). :-)

Having been through this now, I think I have all the items I need:

The sample configuration the tunnel broker suggests for Mac OS X is this:

ifconfig gif0 create
ifconfig gif0 tunnel CLIENT_IPv4_ADDRESS TUNNEL_SERVER_IPv4_ADDRESS
ifconfig gif0 inet6 CLIENT_IPv6_ADDRESS TUNNEL_SERVER_IPv6_ADDRESS prefixlen 128
route -n add -inet6 default TUNNEL_SERVER_IPv6_ADDRESS

These lines might need to be added to PF (it does not hurt to have them even if they might not be needed):

icmp6_types = "{ unreach, toobig, timex, paramprob, echoreq, echorep, neighbradv, neighbrsol, routeradv, routersol }"   
pass inet6 proto ipv6-frag   
pass in on EXT_INTERFACE proto 41 from TUNNEL_SERVER_IPv4_ADDRESS   
pass out on EXT_INTERFACE proto 41 to TUNNEL_SERVER_IPv4_ADDRESS   
pass in on gif0 inet6 proto icmp6 all icmp6-type $icmp6_types allow-opts   

Finally, if the machine is going to gateway IPv6 traffic:

sysctl net.inet6.ip6.forwading=1

 26 
 on: June 19, 2017, 06:22:04 AM 
Started by majortom - Last post by cholzhauer
Is your firewall blocking protocol 41?

 27 
 on: June 18, 2017, 08:17:29 PM 
Started by majortom - Last post by majortom
My router is a mac running 10.12.5. I have it working using the tunnel broker for locally originating IPv6 traffic. It is also able to ping6 one of the other Macs on the local network (and that machine can ping6 it) using my /64. The other mac cannot ping either endpoint on the gif0, nor can it get IPv6 traffic off the local network. I presume I have a setting in PF wrong (or do not have a setting I need), or I do not have the IPv6 gateway enabled. I have searched the net for answers with no luck.

 28 
 on: June 18, 2017, 10:54:35 AM 
Started by lorenzoz - Last post by divad27182
You might try seeing if sending your notification to slave.dns.he.net works any better.  That machine does all the slave transfers anyway.

Failing that, you might write to dnsadmin@he.net.

--David

 29 
 on: June 18, 2017, 10:42:44 AM 
Started by lorenzoz - Last post by divad27182
I think it is supported.  My DNS slave zones on dns.he.net have an IPv6 address listed as the master, and have successfully downloaded.

The bit that you are showing, that might still not be supported, is notification to the slave that the master has changed. 

--David

 30 
 on: June 17, 2017, 09:22:49 PM 
Started by broquea - Last post by agentb
A number of years old, getting discolored now but still my favorite shirt:


Pages: 1 2 [3] 4 5 ... 10